There’s a lot of information on the Internet on how to create bootable media on OS X, and a lot of it doesn’t work. Don’t get tricked into buying special applications for this. Everything you need is already installed on your Mac.

Convert the ISO to an image your Mac can work with

Open the Terminal application. The easiest way is to open Spotlight (CMD+SPACE) and type “Terminal”.

Let’s say you’ve downloaded a file called debian.iso to your Downloads folder. In that case, the command would be:

hdiutil convert -format UDRW -o ~/Downloads/debian.img ~/Downloads/debian.iso

I’ll continue with this example. Don’t forget to change the filenames to whatever you’re using.

Put your fresh image on your USB stick

Make sure your USB device is not plugged in before running this command:

diskutil list

Now, plug in your USB device and run:

diskutil list

Compare the list with the previous one - a device should have been added. In my case, it was indicated as “/dev/disk2 (external, physical)”. This /dev/disk2 is important to note down, we’ll use it in the next step:

diskutil unmountDisk /dev/diskN

(replace N with the disk number from the last command; in the previous example, N would be 2).

sudo dd if=~/Downloads/debian.dmg of=/dev/diskN bs=1m

You will be asked for your password and then nothing happens, but you can be sure you’re computer is cooking a bootable USB stick for you now. This may take a while.

Finished!

If everything is okay, you will see something like this:

2253+1 records in
2253+1 records out
2363277312 bytes transferred in 772.873447 secs (3057780 bytes/sec)

Sources